MSVCR100.dll is missing when WAMP server install

Just share...Share on FacebookShare on Google+Tweet about this on TwitterPin on PinterestShare on RedditShare on StumbleUponEmail this to someone

You may get following error message when installing WAMP,

The program can’t start because MSVCR100.dll is missing from your computer.
Try reinstalling the program to fix this problem.

Step to Install - MSVCR100.dll is missing when WAMP server install - wamp shows error msvcr100.dll is missing when install


After this alert, If you run WAMP it’ll start to run. But WAMP icon color stay in ‘yellow’ color.

It won’t change to ‘Green’ color.

Solution for MSVCR100.dll is missing when WAMP server install

This MSVCR100.dll is missing when WAMP server install problem mostly happen when you install new ‘Operating system’.

That MSVCR100.dll file is one part of Microsoft Visual C++. IF this component is missing means, ‘Apache Server’ won’t run. So, download following exe file and just install that. It’s enough for MSVCR100.dll is missing when WAMP server install problem.

For Windows 32 bit OS:

Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)

Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)

Here just select your Language and click ‘Download’ Button. You will get ‘vcredist_x86.exe’ file. Just Download that file and install as usual( double click ).

For Windows 64 bit OS:

Visual C++ Redistributable for Visual Studio 2012 Update 4

Microsoft Visual C++ 2008 Redistributable Package (x64)

Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)

Here just select your Language and click ‘Download’ Button. You will get ‘vcredist_x64.exe’ file. Just Download that file and install as usual( double click ).

New UPDATE:

If you are using WAMPServer new version 2.5, that’s too need ‘Visual C++ Redistributable for Visual Studio 2012’.
So, If using WAMP 2.5 and getting this error, Go to following link,
Visual C++ Redistributable for Visual Studio 2012 Update 4

Notes:
1) Make sure you have the latest service pack and critical updates for the version of Windows that you are running. To find recent security updates, visit Windows Update.

2)Supported Operating System: Windows 7, Windows Server 2003, Windows Server 2008, Windows Server 2008 R2, Windows Vista, Windows XP

3)Make sure you have the latest version of packages of these Microsoft C++ Redistributable runtime libraries. We recommended 2008 Packages for over-all.

4)This the solution for error: Aestan Tray Menu has stopped working and Exception in module wampmanager.exe at 000F15A0

Just share...Share on FacebookShare on Google+Tweet about this on TwitterPin on PinterestShare on RedditShare on StumbleUponEmail this to someone
The following two tabs change content below.
I am Karthik, software engineer by profession. I'm giving some steps to installing, re-installing, updating, removing and any other related queries about software’s, operating systems, plug-ins and so on. You can find and follow me, from Social Media or here. Google+

82 Responses

  1. Dhan says:

    This post is good for

    The program can’t start because MSVCR100.dll is missing from your computer.
    Try reinstalling the program to fix this problem. “

    • chirag says:

      While installing WAMP in windows7 I’m getting an error of missing MSVCR100.dll file. Even thought I have installed Microsoft Visual C++ 2010 I’m still getting the same error of missing file MSVCR100.dll. What to do now?

  2. Ganesh says:

    Looking good..Thanks for the tips..Keep posting useful posts..

  3. samama says:

    not working

  4. kotichowdary says:

    Thnx a lot….it’s working…..
    keep posting new posta….

  5. Mehul says:

    Thanks a lot….its working..keep posting this type of solution..

  6. ashela says:

    still it gives the same error massage

  7. poltak says:

    I got the clue in this site.
    Thanks for helpful information.
    My problem is already solved.

  8. Abhinandan says:

    Exception in module wampmanager.exe at 000f15A0 could not execute run action the application has fail to start because its side by side configuration is incorrect.

    i got this error message and doesnt run my wamp server

    thank you

  9. Shantharam says:

    help me asap! even if I install Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) on my 32 bit system, wamp server is not starting… it is still showing me the same error. what do i do?

  10. Deb says:

    Thanks a lot. It has worked.

  11. Pawan says:

    thanks bolna toh banta hai boss

  12. Mark says:

    I run Windows Server 2012 (64 bit) – I tried both the 2008 and 2010 downloads but the error message still comes up??

  13. Sadaqat ali says:

    bundle of thanks dear

  14. patrick says:

    Thanx

  15. kunal says:

    still getting the same error…

  16. parthipan says:

    will it work for windows 8.1

  17. Irfan Siddiqui says:

    While installing WAMP in windows7 I’m getting an error of missing MSVCR100.dll file. Even thought I have installed Microsoft Visual C++ 2010 I’m still getting the same error of missing file MSVCR100.dll. What to do now?

  18. brett says:

    Guys please help, still having issues with the same msvcr120.dll error. I have installed both suggestions for my 86bit and no joy. PLEASE HELP!

  19. faisal says:

    what the f*** its not working

  20. Elwin says:

    Thanks, i needed also too install the Microsoft Visual C++ 2012 SP1 Redistributable Package (x86). I have Vista 32bit

  21. siba says:

    not working

  22. Aisha says:

    It is still not working

  23. Ram says:

    which one i neeed to download if the error is “msvcr110.dll is missing from your computer”….

  24. Chandresh says:

    Thank you.. Finally its working

  25. jairo garzon says:

    Hi KarSho, thank for this comment… i like this utility…
    Hail from Bogota Colombia. Bye.

  26. saleh safie says:

    This solution might work for missing msvcr100.dll. I try the same thing for problem missing msvcr110.dll and nothing happen
    I think somthing problem that block the wamp server from using the port or whatever and cause the problem

  27. Walter says:

    Hola!Instale el archivo Msvcr110.dll, lo puse en la carpeta system32, también instale Microsoft Visual C + + 2008 Redistributable Package (x64) como sale en esta pagina y nada sigo teniendo un error y no se puede iniciar el wampserver, esta en color naranja.
    Les agradeceria si me pueden ayudar. Saludos!

  28. 86bit-is-cool says:

    brett, 86-bit operating system is cool. I wish I had one 😀

  29. opia chuks says:

    I have tried it but it dint work. Moreover the file is present on my pc

  30. Anthony Benjamin says:

    Problem is still there.

    I did both uninstall and reinstall.
    Any ideas?

    Anthony

  31. Matt Satler says:

    Works perfectly I installed both versions on my win 7 x64 bit (vcredist_x86 & vcredist_x64)Than re-install wamp.

  32. raju says:

    after installing both versions still i am getting same peroblem

  33. Art says:

    I installed both versions of “Visual C++ Redistributable for Visual Studio 2012 Update 4” then re-installed WAMP and not it works perfectly.. I installed the proper version (x64) of WAMP on my 64 bit windows 7 machine

  34. vinh says:

    I installed “Visual C++ Redistributable for Visual Studio 2012 Update 4”. It works!!!! Thanks alot.

  35. bhavin joshi says:

    not solve my wamp server error MSVCR100.dll is missing this error is not solve any way and repeat to repeat this problem so how i solve this problem please give me solution this dll error fast.

  36. Arun Francis says:

    Thanks man, it really worked

  37. Melrose says:

    I just reinstalled Microsoft Visual C++ 2010…., but then the error “MSVVCR100.dll is missing” is persistent. I cannot start my wampserver due to the missing file. What should I do then? Thank you so much, Sir!

  38. Reni Andayani says:

    thanks a lot, it’s working

  39. Grishma says:

    not solve my wamp server error MSVCR100.dll is missing this error is not solve any way and repeat to repeat this problem so how i solve this problem please give me solution this dll error fast.

  40. C says:

    I got the same message saying ‘cant start the program because msvcr110.dll is missing from your computer’, when trying to install WAMPserver. Downloaded Visual C++ Redistributable for Visual Studio 2012 Update 4 x86 for my 32-bit, tried to run WAMPserver again, nothing happened. Oh well at least it didnt give me ‘msvcr100.dll is missing’ message anymore, but now nothing happened.
    Anyone has similar experience? Help please….

  41. Adarsh says:

    very very helpful info bro 🙂

  42. Sandeep Maurya says:

    Thanks lot buddy

  43. Fahad says:

    thanks a lot friend.
    I try to solve this proble past 2-3 days but your post can helped me and i very happy.
    Thanks again and keep sharing your valuable knowledge to us.

  44. Mohd says:

    Guyz jus keep calm…

    uninstall your wamp, install vcredistributabl.exe, restart your pc, install wamp again and it’s done…

    Thanks for your help admin…

  45. Vibol says:

    It’s useful.
    This guide did help me go through this problem.
    Thank you very much.

  46. Shanthakumara Gowda says:

    —————————
    c:\wamp\bin\apache\apache2.4.9\bin\httpd.exe
    —————————
    c:\wamp\bin\apache\apache2.4.9\bin\httpd.exe is not a valid Win32 application.

    Please instruct me..

  47. suleman says:

    not working.same error missing MSVCR110.dll.please help.

  48. komok says:

    ThanX alooot man…i have downloaded
    “Visual C++ Redistributable for Visual Studio 2012 Update 4”
    on “win 8 64bit” problem solved..keep up the good work

  49. Camilo says:

    Mil gracias fue mi unica solucion gracias.

  50. Shankar Salunkhe says:

    Thanks for help..works pefectly

  51. piyush says:

    thanks it’s working and so helpful….!!

  52. davood says:

    very good thankssssssssssssssssss

  53. johnlucky says:

    my game is still not working

  54. Prabhu Raju says:

    Hi,
    I use window 2008 server standard. I installed all 32 and 64 bit binaries finally after seeing this post i installed VCRedistribute 2012 . Now its is working Thanks to karthick(Karsho) for this helpfull post

  55. jeanc says:

    Thanks a lot. It worked..

  56. Torabi says:

    Dears,
    The following solved the problem for me. I am running windows 7
    Visual C++ Redistributable for Visual Studio 2012 Update 4
    (http://www.microsoft.com/en-us/download/confirmation.aspx?id=30679)

  57. Torabi says:

    But you need to re-install wamp after installing Visual C++ Redistributable for Visual Studio 2012 Update 4

  58. Torsten Kelsch says:

    It works, but I had to uninstall Wamp and reinstall it, like Torabi described.

  59. Colin Elligsen says:

    I have Windows 10 now and I’ve tried all the above steps and nothing has worked so far.

  60. joady says:

    I’ve figured it out i think. The above didn’t work and I couldn’t figure out why. It turns out that the download from sourceforge that I installed was 32 bit. So I installed the 32 bit Visual C++ redistributable and it worked fine. However, then I just uninstalled WAMP and installed the 64 bit version. It worked perfectly. I was forgetting that even though my system is 64 bit, the Wamp and VC++ need to be the same whichever it is. Simples…

  61. deepak says:

    thanks a lot..

  62. haris says:

    i have been same problem plz solution text on me

  63. shahid Mehmood says:

    Sir can you help me to complete my project . I am a student of MCS 3rd semester . Kindly reply me .

  64. Farid says:

    I installed the program , but it was error

  65. Ravindra Khillare says:

    Yo bro…. its working … I was trying from many days to resolve this .dill problem but finally it worked …. aaahhhaaaaa

  66. Aissa says:

    I don’t Found my Bouton Telechargement :'( Wath i doo ??

Leave a Reply

Your email address will not be published. Required fields are marked *

Please Fill this Sum * Time limit is exhausted. Please reload CAPTCHA.